Forumsee logo
Forumsee » Cars » Classic cars » Read message
RSS: Subscribe to RSS

Squeal Under Acceleration

The 1973 - 1987 Chevrolet & GMC Pickups Message Board - The 1947 - Present Chevrolet & GMC Truck Message Board Network - 67-72chevytrucks.com
Hello all, I have 1986 C10 with a 305. I have about 1000 mile on a rebuilt engine. I have a squeal under acceleration(Just started). I have removed all the belts, and checked all vacuum leaks with smoke. I replaced the u joints as a last ditch effort and still no luck. I did notice intermittent water vapor puffs out of the exhaust only on one side under load(wheels chalked and truck in drive) when checking the u joints.

During the rebuild I torqued the head bolts in the proper sequence 3 times, each time letting it sit overnight. I did Not re-torque the bolts after the initial break-in. So here are my questions:

Will a improperly sealed head gasket cause the squeal?

Should I have re-torqued the heads after break-in?

What should be my next step, re-torque the bolts?

Thanks


Read responses in 67-72chevytrucks.com

Tags


Last videos:

Test Driving C3 Corvettes
Test Driving C3 Corvettes
Detroit Auto Show Preview
Detroit Auto Show Preview
I Joined The Flying Roof Club
I Joined The Flying Roof Club
shameless plug for my youtube channel
shameless plug for my youtube channel
The science of dubstep
The science of dubstep
Corvette Engine Deep Clean
Corvette Engine Deep Clean
Whats are your thoughts on the Kia Stinger ?
Whats are your thoughts on the Kia Stinger ?
The Music Video "Skate Away" by Dire Straits
The Music Video "Skate Away" by Dire Straits
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more