Forumsee logo
Forumsee » Cars » Brands and models » Read message
RSS: Subscribe to RSS

02 C230 coupe M111 supercharger rebuild - lost power? Help!

C-Class (W203) - MBWorld.org Forums - mbworld.org
Hey guys I have a 138k miles 2002 c230k coupe with the m111 motor and the eaton m45 supercharger (non-clutch) version. I just got my supercharger back from stiegermeyer porting and they rebuilt the snout, resurfaced the rotors and changed the rear bearings.

I reinstalled my supercharger and noticed a significant loss of power. No check engine light, reinstalled everything back the same way, made sure the bolts were tight, nothing odd to note and everything in the supercharger looked great.

But now it feels like it has lost all its go power, and from 4-6k rpm it seems like there is not enough boost.

Could the supercharger have been rebuilt wrong? Is there something I can do to confirm if the supercharger is bad? Or is there something else I need to do to after reinstalling the supercharger?

To remove this ad, register today or login if you already are registered!

');


Read responses in mbworld.org

Tags


Last videos:

My Supercharged C7 Corvette
My Supercharged C7 Corvette
Long Beach Gran Prix - 3 Part Vlog Series
Long Beach Gran Prix - 3 Part Vlog Series
Steering Joint upgrade
Steering Joint upgrade
Whores Round Here vs THE WORLD
Whores Round Here vs THE WORLD
Repainting Brake Calipers
Repainting Brake Calipers
What if u could turn 14 RPM
What if u could turn 14 RPM
CR-Z on YouTube
CR-Z on YouTube
Test Driving C3 Corvettes
Test Driving C3 Corvettes
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more