Forumsee logo
Forumsee » Cars » Maintenance & Repairs » Read message
RSS: Subscribe to RSS

1994 LS1/T6 Nissan 300ZX

Conversions & Hybrids - LS1TECH - ls1tech.com
Hello,

I started finally driving my LS swapped Z on a more regular basis. The swap was done before there were really any kits for these cars. Everything works in the factory gauge cluster, except the speedometer and the tach. The oil gauge, temp gauge, etc. work. Any ideas on how to get these to work? I am sure the tach is just a matter of tapping into the stock ECU tach wire? I usually log with HP tuners, so I can see the RPM there - but it would be nice to have the cluster working correctly. Speedometer...I'm not really sure.

I have also thought of just running a Racepak dash or something like that, but I like the stock cluster. Thanks!


Read responses in ls1tech.com

Tags


Last videos:

Long Beach Gran Prix - 3 Part Vlog Series
Long Beach Gran Prix - 3 Part Vlog Series
Steering Joint upgrade
Steering Joint upgrade
Whores Round Here vs THE WORLD
Whores Round Here vs THE WORLD
Repainting Brake Calipers
Repainting Brake Calipers
What if u could turn 14 RPM
What if u could turn 14 RPM
CR-Z on YouTube
CR-Z on YouTube
Test Driving C3 Corvettes
Test Driving C3 Corvettes
Detroit Auto Show Preview
Detroit Auto Show Preview
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more