Forumsee logo
Forumsee » Cars » Maintenance & Repairs » Read message
RSS: Subscribe to RSS

Nissan - Rough Idle / Running Rich after Supercharger and Z1 Tune

Forced Induction - Nissan 370Z Forum - www.the370z.com
Hey guys,

Firstly, thank you to anyone who helps me on this issue!

So let me explain a little about what is going on..

I installed a STILLEN SC kit on my car not to long ago (2months) and had it hauled to Z1Motorsports so Jon could tune it. He did so getting the car around 425wp and everything ran fine. Even from the shop I had an studder in my acceleration once in a blue moon.

A week or so after the custom tune I notice when cold start or even at a warm idle the wideband would surge, bounce from like 15.8-13.7 approx. You could hear it in the exhaust note too.

NOW my issue is that upon cold start and even warm idle, say at a redlight my wideband stays around 10.0-10.5!!! and the idle acts very odd, choppy almost.

MOD LIST:

Stillen Supercharger

TBatts anti-slip pulley kit

1000cc ID Injectors

Turbosmart 25mm BOV

UPRev custom Z1motorsports Tune

Frozenboost exchange

Custom exhaust

Picture of wideband at idle:
Date: Oct 10, 2017    Labels: Nissan


Last videos:

is this Nuno's office?
is this Nuno's office?
New Ls7 Stock Bottom End Record!
New Ls7 Stock Bottom End Record!
how to use your LS6
how to use your LS6
DPF overview
DPF overview
Air Filter Horror Story
Air Filter Horror Story
Mr Clean Paint Correction
Mr Clean Paint Correction
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
12 year old LS1 with a 200 shot of Nitrous
12 year old LS1 with a 200 shot of Nitrous

Tags

Cars ·
Travel ·
production-frontend