Forumsee logo
Forumsee » Cars » Maintenance & Repairs » Read message
RSS: Subscribe to RSS

Horn stopped working/Suspension problems

Repair & Maintenance - NewCelica.org Forum - newcelica.org
My first problem is my horn stopped working. I don't use it too often and I tried to about a week ago but it no longer works. I popped the hood and I can hear the horn relay clicking when I press on the horn. This makes me think the horn is just no good but my cruise and airbag light have been flashing since I got the car and when I turn the wheel to the right I can hear the clockspring/spiral cable making noise. I saw on here that somebody was having the same problem and many thought it was the clockspring but the problem was never solved. If the clockspring was bad wouldn't the horn relay not make any sound?

My second problem is when I turn the wheel far left or right, at about 3/4 turned it just turns itself hard the rest of the way and stays there and I hear a clunk sound. The wheel also won't spring back it'll just stay there and make my car do circles all day long. I also have a problem with my car shifting back and forth and even sometimes turning pretty bad to one side when I brake. I'm thinking my cv axle maybe?

Any help on these problems would be greatly appreciated
Date: Jun 7, 2013   


Last videos:

is this Nuno's office?
is this Nuno's office?
New Ls7 Stock Bottom End Record!
New Ls7 Stock Bottom End Record!
how to use your LS6
how to use your LS6
DPF overview
DPF overview
Air Filter Horror Story
Air Filter Horror Story
Mr Clean Paint Correction
Mr Clean Paint Correction
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
12 year old LS1 with a 200 shot of Nitrous
12 year old LS1 with a 200 shot of Nitrous

Tags

Cars ·
Travel ·
production-frontend