Forumsee logo
Forumsee » Cars » Brands and models » Read message
RSS: Subscribe to RSS

02 C230 coupe M111 supercharger rebuild - lost power? Help!

C-Class (W203) - MBWorld.org Forums - mbworld.org
Hey guys I have a 138k miles 2002 c230k coupe with the m111 motor and the eaton m45 supercharger (non-clutch) version. I just got my supercharger back from stiegermeyer porting and they rebuilt the snout, resurfaced the rotors and changed the rear bearings.

I reinstalled my supercharger and noticed a significant loss of power. No check engine light, reinstalled everything back the same way, made sure the bolts were tight, nothing odd to note and everything in the supercharger looked great.

But now it feels like it has lost all its go power, and from 4-6k rpm it seems like there is not enough boost.

Could the supercharger have been rebuilt wrong? Is there something I can do to confirm if the supercharger is bad? Or is there something else I need to do to after reinstalling the supercharger?

To remove this ad, register today or login if you already are registered!

');
Date: Feb 26, 2013   


Tags


Last videos:

Detroit Auto Show Preview
Detroit Auto Show Preview
I Joined The Flying Roof Club
I Joined The Flying Roof Club
shameless plug for my youtube channel
shameless plug for my youtube channel
The science of dubstep
The science of dubstep
Has this been posted before now?
Has this been posted before now?
Could The Mid-Engine Corvette Actually Be A C7?
Could The Mid-Engine Corvette Actually Be A C7?
C5 Touch Up Paint
C5 Touch Up Paint
Air Filter Horror Story
Air Filter Horror Story
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more