Forumsee logo
Forumsee » Cars » Brands and models » Read message
RSS: Subscribe to RSS

2003 V10 has sudden issues, doesn't want to run

3rd Gen Ram Tech - DodgeForum.com - dodgeforum.com
I sold the 2003 V10 in my signature to my dad to use as a work truck. Almost immediately after I sold it, it had a plethora of problems. Now, before I sold it, the only real problem is that when cold, the engine didn't want to idle reliably; it would stall out and die, but crank right back up. After driving several miles, though, this problem went away. After I sold it, the double u-joint in the front driveshaft broke (I wasn't driving it at the time, btw ). The result was it flopping around wildly until I unbolted it from the front axle. After this, the truck ran worse and worse over the course of one day, from being fine to shutting down while rolling. A day later, it would crank, start, run okay for a few moments, spit, sputter and die, regardless of working the throttle. It is still in this state. Cranking immediately after this results in a no-start, but if you turn the key off, wait a second and try again, it will start again. Heaven help you if you try to put it in gear and try to move, it's almost impossible because the truck immediately wants to stall out. I suspected the fuel pump and replaced it, with no change. I also replaced the cam sensor, again with no change. I towed it to my shop and crawled under it, thinking maybe the driveshaft may have broke the wiring harness. All the wires seem fine, except the wires for the O2 sensor behind the two main upstreams and before the catalytic converter, which seem to have been snagged and torn previously. These are the codes I pulled, in this order:

P0303 Cylinder 3 misfire

P0135 O2 Heater Circuit (Bank 1 Sensor 1)

P0132 O2 Circuit High Voltage (Bank ! Sensor 1)

P0155 O2 Heater Circuit (Bank 2 Sensor 1)

P1757 Transmission Governor pressure high

P0455 Evap Leak (gross/ no flow)

P0141 O2 Heater Circuit (Bank 1 Sensor 2)

P0300 Random misfire

P0442 Evap leak (small leak)

P0306 Cylinder 6 Misfire

P0304 Cylinder 4 misfire

P1391 Intermittent loss of CMP or CKP

I feel bad for my dad and I'm trying to fix it for him, but I'm at a loss. The computer went out on it a few years ago and I had the dealership replace it. I can't imagine what else to look at. Everything seems to have happened after the front driveshaft broke. All my mechanic buddies said while the O2 sensors need to be replaced, they should not be causing this level of chaos. Any thoughts? Thanks!!
Date: Oct 13, 2017   


Last videos:

Are you getting the ZR1?
Are you getting the ZR1?
How to remove Heater Core on a 1963, Video
How to remove Heater Core on a 1963, Video
How to remove Heater Core on a 1963, Video
How to remove Heater Core on a 1963, Video
MCL Ride-Alongs: New Segment on my YouTube Channel
MCL Ride-Alongs: New Segment on my YouTube Channel
1981 factory footage
1981 factory footage
ZR1 On Track
ZR1 On Track
Check This Fast N' Loud Find!
Check This Fast N' Loud Find!
Has this been posted before now?
Has this been posted before now?

Tags

Cars ·
Travel ·
Pets ·
production-frontend