Forumsee logo
Forumsee » Cars » Maintenance & Repairs » Read message
RSS: Subscribe to RSS

1994 LS1/T6 Nissan 300ZX

Conversions & Hybrids - LS1TECH - ls1tech.com
Hello,

I started finally driving my LS swapped Z on a more regular basis. The swap was done before there were really any kits for these cars. Everything works in the factory gauge cluster, except the speedometer and the tach. The oil gauge, temp gauge, etc. work. Any ideas on how to get these to work? I am sure the tach is just a matter of tapping into the stock ECU tach wire? I usually log with HP tuners, so I can see the RPM there - but it would be nice to have the cluster working correctly. Speedometer...I'm not really sure.

I have also thought of just running a Racepak dash or something like that, but I like the stock cluster. Thanks!
Date: Jan 14, 2018   


Tags


Last videos:

Detroit Auto Show Preview
Detroit Auto Show Preview
I Joined The Flying Roof Club
I Joined The Flying Roof Club
shameless plug for my youtube channel
shameless plug for my youtube channel
The science of dubstep
The science of dubstep
Has this been posted before now?
Has this been posted before now?
Could The Mid-Engine Corvette Actually Be A C7?
Could The Mid-Engine Corvette Actually Be A C7?
C5 Touch Up Paint
C5 Touch Up Paint
Air Filter Horror Story
Air Filter Horror Story
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more