Forumsee logo
Forumsee » Cars » Maintenance & Repairs » Read message
RSS: Subscribe to RSS

Toyota - Help my Toyota won't accelerate

Repairs & Maintenance - CarForums.com - www.carforums.com
I drive a 2009 Toyota Camry LE 4 cylinder and I'm going from Massachusetts to Utah. They car was running perfectly fine until I got to Illinois. I was pulling out of a toll and suddenly the car struggled to accelerate no matter how hard I pressed on the gas pedal until it leaped forward and started to drive and would continue to go as long as I stayed at a steady speed until I slowed down or stopped. This continued to happen. If I turned off the car and back on again it would work for a minute or two until it began again. I checked the transmission fluid and it was full, and it looked fine and didn't smell burnt at all. I did recently get a pipe on the catalytic converter repaired if that has anything to do with it. Does this seem like my transmission is dying, or the O2 sensor, or my fuel filter? The car was sitting for half a year and when I took it to the garage to repair the catalytic converter and get new breaks I asked them to check the entire car, but they never mentioned anything.

-
Date: Oct 2, 2017    Labels: Toyota


Last videos:

is this Nuno's office?
is this Nuno's office?
New Ls7 Stock Bottom End Record!
New Ls7 Stock Bottom End Record!
how to use your LS6
how to use your LS6
DPF overview
DPF overview
Air Filter Horror Story
Air Filter Horror Story
Mr Clean Paint Correction
Mr Clean Paint Correction
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
New YouTube Video! My Turbo Trans Am on the dyno. Do I still have 1000 Horsepower
12 year old LS1 with a 200 shot of Nitrous
12 year old LS1 with a 200 shot of Nitrous

Tags

Cars ·
Travel ·
production-frontend